2.2. ファイルの圧縮と解凍

KDE には、アーカイブファイルの作成やファイルを圧縮するための Ark と呼ばれるツールが付属しています。アーカイブとは、複数のファイルを 1 つにまとめたファイルのことを言います。グラフィカルなインターフェースで操作ができますので、コマンドを使うことなく、簡単にアーカイブの作成/展開やファイルの圧縮/解凍が行えます。また、Ark は、ファイルマネージャ(Konqueror)と密接な関連にあるため、ファイルマネージャ上でも動作します。

Linux の環境で最も一般的に使われているアーカイブファイルの形式は tar と呼ばれる形式です。また、ファイルの圧縮形式としては gzip や bzip2 が一般的に使用されています。gzip 形式で圧縮したファイルの拡張子には ".gz" が付きます。また、bzip2 で圧縮されたファイルの拡張子には ".bz2" が付きます。".tar.gz" や ".tar.bz2" という拡張子の付いたファイルをインターネット上でよく見かけますが、これは、tar でアーカイブを作成した後に、gzip や bzip2 で圧縮したファイルであることを表しています。Ark はこれらのファイル形式を問題なく扱うことができます。また、Windows でよく使われている zip 形式のファイルも扱うことができますので、Linux 上で zip ファイルを作成すれば、Windows でも問題なく展開、解凍することができます。

2.2.1. ファイルマネージャでの操作

アーカイブファイルの表示

ファイルマネージャを使用するとアーカイブファイルであることをまったく意識せずに、通常のフォルダやファイルと同じようにアーカイブファイル内のフォルダに移動したり、ファイルを扱うことができます。例えば、zip で圧縮された "MyDocument.zip" というファイルは、ファイルマネージャでは のアイコンで表示されます。

このアイコンをダブルクリックするだけで、アーカイブファイルの内容が表示されます。

このように、通常のフォルダやファイルと同じようにファイルマネージャ上でアーカイブファイルの中身を確認することができます。

アーカイブファイルの作成

ファイルマネージャに表示されているフォルダやファイルを右クリックし、"アクション" メニューを表示します。

"フォルダを ZIP 圧縮する"、あるいは "ファイルを ZIP 圧縮する" を選択して、簡単にファイルやフォルダを zip 形式で圧縮することができます。他の形式のアーカイブファイルを作成したい場合は、圧縮解凍ツールを使用してください(項2.2.2 参照)。

アーカイブファイルの展開

ファイルマネージャに表示されているアーカイブファイルを右クリックし、"圧縮解凍ツールで開く" を選択します。

以下のように圧縮解凍ツールが起動し、アーカイブファイルの中身がリスト表示されます。

ツールバーの アイコンをクリックしてアーカイブを展開することができます。圧縮解凍ツールについては、項2.2.2 を参照してください。

2.2.2. 圧縮解凍ツール(Ark)の操作

Ark の起動

Ark を起動するには、パネルの "メニュー" から "プログラム" -> "ユーティリティ" -> "圧縮解凍ツール" を選択します。

ティップ

ファイルマネージャでアーカイブファイルを右クリックして表示されるメニューから "圧縮解凍ツール" を選択して Ark を起動することもできます。

アーカイブファイルの作成

新規にアーカイブファイルを作成するには、メニューバーから "ファイル" -> "新規" を選択します。または、ツールバーの アイコンをクリックします。以下の画面が表示されます。

アーカイブファイルを保存したいフォルダへ移動し、"場所" にアーカイブファイル名を入力します。アーカイブファイルの形式は、"フィルタ" プルダウンメニューから選択することができます。指定したら[保存]ボタンをクリックします。

ティップ

gzip(gz)や bzip(bz2)では、1 つのファイルを圧縮するだけで複数のファイルをアーカイブすることはできません。複数ファイルをアーカイブして圧縮したい場合は ".tar.gz"、".tar.bz2"、"zip" 等を選択します。

新しいアーカイブファイルを作成したら、そのアーカイブに格納するファイルを選択します。ファイル単位で指定する場合はメニューバーから "アクション" -> "ファイルを追加" を選択します。または、ツールバーの アイコンをクリックします。以下の画面が表示されます。

追加したいファイルを選択し[OK]ボタンをクリックします。

フォルダ単位で指定する場合は、メニューバーから "アクション" -> "フォルダを追加" を選択します。または、ツールバーの アイコンをクリックします。以下の画面が表示されます。

フォルダを選択して[OK]ボタンをクリックします。

ティップ

ファイルマネージャからファイルやフォルダをドラッグ&ドロップして追加することも可能です。

以下のように追加したファイルやフォルダがリスト表示されます。

アーカイブファイルに格納したファイルを削除したい場合は、削除するファイルを選択し、ツールバーの アイコンをクリックします。

アーカイブファイルの展開

既存のアーカイブファイルを展開するには、メニューバーから "ファイル" -> "開く" を選択します。または、ツールバーから アイコンをクリックします。以下の画面が表示されます。

アーカイブファイルを選択し[OK]ボタンをクリックします。以下のようにアーカイブファイルに格納されているファイルやフォルダがリスト表示されます。

ファイルを展開するには、メニューバーから "アクション" -> "展開" を選択するか、ツールバーの アイコンをクリックします。アーカイブを全て展開するのではなく、リストで選択したファイルやリストだけを展開することもできます。以下の画面が表示されます。

"展開先" にフォルダを指定します。アーカイブファイルを全て展開するのであれば "全て"、選択したファイルやフォルダだけを展開するのであれば "選択されたファイル" を選択して[OK]ボタンをクリックします。これで指定したフォルダに展開されます。

アーカイブファイルの表示

Ark はアーカイブファイル内に格納されたファイルを実際に展開することなく、参照することもできます。ファイルを開くには、ファイルを選択し、ツールバーの アイコンをクリックします。そのファイルに関連付けされたアプリケーションが起動し、ファイルが表示されます。